Postfach streikt bei der Migration von Exchange auf 2013

Bei der Migration von einem Exchange 2007 Server auf Exchange 2013 liefen die MoveRequests für alle Postfächer hervorragend durch, bis auf eines. Der MoveRequest ist irgendwie (evtl. wurde der Quellserver zwischendurch neugestartet) in einen Zustand gekommen, bei dem die Synchronisation immer an einem bestimmten Ordner hängen geblieben ist.

Um ĂĽberhaupt Fehlermeldungen zum MoveRequest ins EventLog zu bekommen, folgenden Befehl in der Exchange Shell ausfĂĽhren:

Set-EventLogLevel -identity "MSExchange Mailbox Replication\Mailbox Move" -level High

Nach langem tĂĽfteln ist mir aufgefallen, dass das Quellpostfach ungĂĽltige Regeln hatte. Nach dem Entfernen derselben startete der MoveRequest immer mit den bereits synchronisierten Nachrichten, und verabschiedete sich immer mit folgender Meldung:

VorĂĽbergehender Fehler bei Postfachreplikationsdienst 'contoso.local/MyBusiness/Users/SBSUsers/Example User' (c0dea3be-4857-4509-b39f-ced8caa6beef). Der Vorgang wird erneut versucht (8 von 60).
Fehlercode: -2147221233
MapiExceptionNotFound: Unable to synchronize manifest. (hr=0x8004010f, ec=-2147221233)
Diagnostic context:
    Lid: 45095   EMSMDB.EcDoRpcExt2 called [length=304]
    Lid: 61479   EMSMDB.EcDoRpcExt2 returned [ec=0x0][length=235][latency=1]
    Lid: 52176   ClientVersion: 15.0.995.27
    Lid: 50032   ServerVersion: 8.3.392.0
    Lid: 23226   --- ROP Parse Start ---
    Lid: 27962   ROP: ropIncrCfg [112]
    Lid: 27962   ROP: ropUpldStStrmBegin [117]
    Lid: 27962   ROP: ropUpldStStrmEnd [119]
    Lid: 27962   ROP: ropUpldStStrmBegin [117]
    Lid: 27962   ROP: ropUpldStStrmEnd [119]
    Lid: 27962   ROP: ropUpldStStrmBegin [117]
    Lid: 27962   ROP: ropUpldStStrmEnd [119]
    Lid: 27962   ROP: ropUpldStStrmBegin [117]
    Lid: 27962   ROP: ropUpldStStrmEnd [119]
    Lid: 27962   ROP: ropFXSrcGetBufferEx [156]
    Lid: 17082   ROP Error: 0x8004010F
    Lid: 23137  
    Lid: 21921   StoreEc: 0x8004010F
    Lid: 27962   ROP: ropExtendedError [250]
    Lid: 1494    ---- Remote Context Beg ----
    Lid: 26426   ROP: ropFXSrcGetBufferEx [156]
    Lid: 13492   StoreEc: 0xFFFFF9BD
    Lid: 2670    StoreEc: 0xFFFFF9BD
    Lid: 21970   StoreEc: 0xFFFFF9BD PropTag: 0x67A61014
    Lid: 2158    StoreEc: 0xFFFFF9BD
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x67A40014
    Lid: 29154   StoreEc: 0x8004010F
    Lid: 3454    StoreEc: 0x8004010F
    Lid: 3742    StoreEc: 0x8004010F
    Lid: 2526    StoreEc: 0x8004010F
    Lid: 1750    ---- Remote Context End ----
    Lid: 26849  
    Lid: 21817   ROP Failure: 0x8004010F
    Lid: 32758  
    Lid: 16586   StoreEc: 0x8004010F
    Lid: 22518  
    Lid: 28874   StoreEc: 0x8004010F
    Lid: 29516  
    Lid: 31820   StoreEc: 0x8004010F
Kontext:
--------
Operation: ISourceFolder.EnumerateChanges
Operation: ISourceFolder.EnumerateChanges
OperationSide: Source
c0dea3be-4857-4509-b39f-ced8caa6beef (Primär)
flags: Catchup
maxChanges: 0
--------
Folder: '/Top of Information Store/Posteingang/Contoso Project', entryId [len=46, data=000000009410D9AA60671A4ABD263B6330524CAFEAFFE7EB1BADC19C6A4396FE525E5A6754180050BEEF008D0000], parentId [len=46, data=000000009410D9AA60671A4ABD263B63305248300100604FFC44BD5C684CBBE823CAFEAFFE1E0006BEEF27F10000]

Die Lösung war relativ simpel: Einfach den MoveRequest dazu zwingen alles neu zu kopieren. Folgende Befehle waren dazu nötig:

New-MoveRequest -Identity ExampleUser -ForceOffline -IncrementalSyncInterval 00:00:00

Dieser Eintrag ist der 3rd älteste. Er ist 357 Wörter lang, und hat bisher 0 Kommentare.